In Mathematica, stylesheets define the look and behavior of elements in a notebook. One can create a custom stylesheet to define the default style for new notebooks.

The recommended steps for doing so are to:

  • define desired custom styles in a new stylesheet,
  • save this stylesheet to the appropriate location and
  • configure Mathematica to use it for all new notebooks.

Creating and Saving a Custom Stylesheet

  1. Open a new notebook.
  2. Select menu item Format ► Edit Stylesheet. An empty Style Definitions notebook will open.
  3. Alter the style for each cell type you wish to modify. Note that any styles you do not change will retain their default behavior defined in Default.nb.

    In this example, we are changing the color of the text in Section cells to blue.
  4. Use File ► Save As to save this new stylesheet to your $UserBaseDirectory\SystemFiles\FrontEnd\Stylesheets directory. For example, on Windows, the default location is:

    C:\Users\<myusername>\AppData\Roaming\Mathematica\SystemFiles\FrontEnd\StyleSheets\

Setting a Custom Stylesheet as the New Default

To set a custom stylesheet as the default, the DefaultStyleDefinitions option needs to contain the stylesheet’s file location.

  1. Go to menu item Format ► Option Inspector. This opens the Option Inspector dialog.
  2. Change the scope from Selection to Global Preferences. This ensures that all new notebooks will be affected.
  3. Look up the option DefaultStyleDefinitions or browse to it via Global Options ► File Locations.
  4. Select the small gray button to the right of the option value to open up a file browser. Select the stylesheet saved earlier.
  5. Open a new notebook and use some of the styles you modified to verify that the changes are being applied.