The best way to test your internet connectivity is using the Preferences dialog (Edit > Preferences). From the Preferences dialog, select the Internet Connectivity tab and then click Test Internet Connectivity. If the internet connectivity test succeeds, Mathematica should be able to use the internet. This means that the live updating system for documentation and data collections should work normally. If Mathematica reports that the internet connectivity test failed, try the following troubleshooting tips.

Check Proxy Issues

You can inspect the current proxy settings in two ways. You can click Edit > Preferences to open the Preferences dialog. When it is open, click the Internet Connectivity tab to show connectivity options, and click the Proxy Settings opener to show the proxy settings and edit them according to the configuration of your internet connection.

Alternatively, you can evaluate $InternetProxyRules. In the resulting list, look at the field, UseProxy->val.
• If val is False, then Mathematica is bypassing proxies and connecting directly to the internet.
• If val is Automatic, then Mathematica is using the same settings as Internet Explorer. If you can connect to web sites using Internet Explorer, then Mathematica should work as well.
• If val is True, then Mathematica is using the values that follow in the $InternetProxyRules list. These values are ignored unless UseProxy->True.

The default setting for UseProxy should be Automatic.

Use the UseInternetProxy function to set the UseProxy value.

In[1]:= UseInternetProxy[Automatic]

You can also use the SetInternetProxy function to assign specific proxies to protocols. See the following example.

In[2]:= SetInternetProxy["HTTP", {"proxy.compnay.com", 8080}]

Please note that if Internet Explorer is set up to use a proxy configuration script, Mathematica cannot use the same values. You will have to set proxies manually using SetInternetProxy. You can find the proxy settings by launching Internet Explorer, clicking Tools > Internet Options, and clicking the Connections tab.