Wolfram Computation Meets Knowledge

What are the System Modeler 12.0 system requirements?

Hardware Specifications

  • Processor: Intel Pentium IV 1.6 GHz or equivalent
  • Disk Space: 2 GB
  • System Memory (RAM): 4 GB

Available Platforms

  • Windows
  • macOS
  • Linux

Available Languages

  • English
  • Japanese
  • Microsoft Windows 64-bit
    Windows 10
    Windows 8
    Windows 7

    System Modeler requires Microsoft Visual Studio to be installed. Visual C++ Build Tools can be installed for free.

    macOS 64-bit
    macOS 10.15 (Catalina)
    macOS 10.14 (Mojave)
    macOS 10.13 (High Sierra)
    macOS 10.12 (Sierra)
    macOS 10.11 (El Capitan)
    macOS 10.10 (Yosemite)

    System Modeler requires Xcode to be installed. Xcode can be installed for free from the Mac App Store. If System Modeler is not autodetecting Xcode 11, see our support article for help.

    Linux 64-bit
    Ubuntu
    Debian
    openSUSE
    Fedora

    System Modeler requires a C++ compiler to be installed. The recommended compiler is G++.

    System Modeler has been tested on the distributions above, but is likely to function on most recent major Linux distributions.

    System Modeler 12 is compatible with the Modelica Standard Library (MSL) 3.2.2, 3.2.1 and 3.1.

Is this article helpful?
Yes
No

Any comments?

Thank you for your feedback.

Submit

Contact Support

Whether you have a question about billing, activation or something more technical, we are ready to help you.

1-800-WOLFRAM (+1-217-398-0700 for international callers)

Customer Support

Monday–Friday
8am–5pm US Central Time

  • Product registration or activation
  • Pre-sales information and ordering
  • Help with installation and first launch

Advanced Technical Support (for eligible customers)

Monday–Thursday
8am–7pm US Central Time

Friday
8:30–10am & 11am–5pm US Central Time

  • Priority technical support
  • Product assistance from Wolfram experts
  • Help with Wolfram Language programming
  • Advanced installation support