Wolfram Computation Meets Knowledge

Wie installiere ich das Wolfram Workbench-Plugin für Eclipse?

Wolfram Workbench ist das empfohlene Werkzeug für die Programmierung in der Wolfram Language außerhalb der Notebook-Bedienoberfläche. Wolfram Workbench ist ein Plugin für Eclipse, eine beliebte und robuste IDE.

Wolfram Workbench benötigt die folgende Software:

Wir empfehlen, die neueste Version dieser IDEs zu installieren, bevor Sie das Wolfram Workbench-Plugin einrichten.

Um Wolfram Workbench einzurichten, installieren Sie das Plugin innerhalb von Eclipse und konfigurieren es so, dass es auf Ihre Mathematica-Installation verweist:

  1. Starten Sie Eclipse.
  2. Gehen Sie im Menü auf Hilfe ► Install New Software (Neue Software installieren). Der Dialog Verfügbare Software erscheint.
  3. Klicken Sie auf die Schaltfläche “Add” (Hinzufügen) in der oberen rechten Ecke.
  4. Geben Sie einen Namen wie “Wolfram Workbench” in das Namensfeld und http://workbench.wolfram.com/update/ in das Feld “Location” ein.


  5. Wenn Sie das Plugin bereits über Ihr Wolfram-Konto heruntergeladen haben, klicken Sie auf “Archive”, um WorkbenchUpdate_10.x.zip zu finden und es direkt hinzuzufügen.

  6. Klicken Sie auf “OK”, um die Standortinformation zu bestätigen. Eine List von Wolfram Workbench-Plugins wird nun angezeigt.
  7. Wählen Sie “Wolfram Workbench Core”. Wählen Sie zusätzlich “Wolfram Workbench webMathematica”, wenn Sie mit webMathematica arbeiten wollen. Bestätigen Sie mit “Next”.
  8. Klicken Sie im Fenster “Install Details” auf “Next”.
  9. Prüfen Sie im Fenster “Review Licenses” die Lizenzvereinbarungen und akzeptieren Sie die Bedingungen. Klicken Sie auf “Finish”, um die Installation zu beginnen.
  10. Wolfram Workbench wird nun installiert. Während der Installation kann eine Sicherheitswarnung über unsignierte Inhalte erscheinen. Klicken Sie auf “Install anyway” (Trotzdem installieren), um fortzufahren.
  11. Starten Sie Eclipse neu, damit die Änderungen wirksam werden.

Das Wolfram Workbench-Plugin ist nun installiert. Um dies zu überprüfen, wählen Sie Help ► About Eclipse und suchen Sie das Wolfram Workbench-Logo im unteren Bereich des Fensters.

Das Wolfram Workbench-Plugin konfiguieren

Wenn mehrere Versionen von Mathematica auf Ihrem Rechner installiert sind, können Sie auswählen, welche Version von Wolfram Workbench Sie verwenden möchten.

  1. Öffnen Sie die Eclipse-Einstellungen (Windows/Linux: Window ► Preferences, Mac: Eclipse ► Preferences).
  2. Wählen Sie die Kategorie Wolfram auf der linken Seite des Fensters Preferences/Einstellungen. Die verfügbaren Wolfram Engines werden angezeigt.

    Installierte Mathematica-Versionen innerhalb der Liste können mit “Edit” bearbeitet werden oder weitere Installationen durch “Add” hinzugefügt werden, indem Sie den Produktnamen und den Installationspfad eingeben.

  3. Wählen Sie Ihre bevorzugte Wolfram Engine-Installation aus. Bestätigen Sie mit “OK”.

[English]

Ist dieser Artikel hilfreich?
Ja
Nein

Kommentare?

Danke für Ihr Feedback.

Senden

Support kontaktieren

Egal, ob Sie eine Frage zur Rechnung, Aktivierung oder zu einer technischen Angelegenheit haben, wir sind da, um Ihnen zu helfen.

1-800-WOLFRAM (+1-217-398-0700 für internationale Anrufer)

Kundendienst

Montag–Freitag
8:00–17:00 US Central Time

  • Produktregistrierung oder Aktivierung
  • Kaufinformationen und Bestellung
  • Hilfe beim Installieren und Starten

Erweiterter technischer Support (für berechtigte Kunden)

Montag–Donnerstag
8:00–19:00 US Central Time

Freitag
8:30–10:00 & 11:00–17:00 US Central Time

  • Technischer Priority-Support
  • Produktassistenz von Wolfram-Experten
  • Hilfe beim Programmieren mit der Wolfram Language
  • Erweiterter Support beim Installieren