Wolfram Computation Meets Knowledge

¿Cómo instalar el complemento Wolfram Workbench para Eclipse?

Wolfram Workbench es la herramienta recomendada para programar en Wolfram Language sin utilizar la interfaz de cuadernos. Wolfram Workbench es un complemento para Eclipse, un IDE sólido y popular.

Wolfram Workbench requiere el siguiente software:

Recomendamos que cuente con las versiones más recientes de este software antes de configurar el complemento Wolfram Workbench.

Para configurar Wolfram Workbench, instale el complemento dentro de Eclipse configúrelo para apuntar hacia su instalación de Mathematica:

  1. Inicie Eclipse.
  2. En el menú, seleccione “Help ► Install New Software”. El diálogo de software disponible aparecerá.
  3. Haga clic en el botón “Add” en la esquina superior derecha.
  4. Ingrese un nombre como “Wolfram Workbench” en el campo de nombre y en el http://workbench.wolfram.com/update/ campo de ubicación.


  5. Si ya ha descargado el complemento desde su cuenta Wolfram, haga clic en “Archive” para ubicar el archivo “WorkbenchUpdate_10.x.zip” y agregarlo directamente.

  6. Haga clic en “OK” para confirmar la información del sitio. Se mostrará una lista de complementos Wolfram Workbench.
  7. Seleccione Wolfram Workbench Core. Adicionalmente, seleccione Wolfram Workbench webMathematica si piensa trabajar con webMathematica. Haga clic en “Next” para confirmar.
  8. En la ventana “Install Details”, haga clic en “Next”.
  9. En la ventana “Review Licenses”, revise y acepte los términos de los acuerdos de licencia. Haga clic en “Finish” para iniciar la instalación.
  10. Wolfram Workbench se instalará. Puede que durante la instalación aparezca un mensaje sobre contenido no firmado, haga clic en “Install anyway” para continuar.
  11. Reinicie Eclipse para que los cambios surtan efecto.

El complemento Wolfram Workbench ha sido instalado. Para verificarlo, diríjase a “Help ► About Eclipse” e identifique el logo de Wolfram Workbench en la parte inferior de la ventana.

Cómo configurar el complemento Wolfram Workbench

Si cuenta con múltiples versiones de Mathematica instaladas en su equipo, puede seleccionar la versión que desee que Wolfram Workbench utilice.

  1. En Eclipse, abra el menú “Preferences” (En Windows/Linux: “Window ► Preferences”, en macOS: “Eclipse ► Preferences”).
  2. Seleccione la categoría Wolfram en la sección izquierda de la ventana “Preferences”. Se mostrarán las versiones disponibles de Wolfram Engines.

    Las versiones instaladas de Mathematica en la lista pueden ser editadas seleccionando “Edit”, también puede agregar otras instalaciones seleccionando “Add” e ingresando el nombre del producto y la ruta de instalación.

  3. Elija su instalación preferida de Wolfram Engine. Haga clic en “OK” para confirmar.

[English]

¿Le parece útil este artículo?
No

¿Tiene algún comentario?

Gracias por sus comentarios.

Enviar

Contacte a soporte técnico

Estamos listos para ayudarlo a resolver sus preguntas sobre facturación, activación o problemas técnicos.

1-800-WOLFRAM (+1-217-398-0700 para usuarios internacionales)

Soporte al cliente

Lunes–viernes
8am–5pm hora estándar del centro

  • Registro o activación del producto
  • Información y ordenes de preventas
  • Ayuda con la instalación y primera ejecución

Soporte técnico avanzado (para clientes admisibles)

Lunes–Jueves
8am–7pm hora estándar del centro

Viernes
8:30–10am y 11am–5pm hora estándar del centro

  • Soporte técnico prioritario
  • Asistencia sobre el producto por expertos Wolfram
  • Ayuda con la programación de Wolfram Language
  • Soporte de instalación avanzado