Wolfram Computation Meets Knowledge

How do I install the Wolfram Workbench plugin for Eclipse?

Wolfram Workbench is the recommended tool for programming in the Wolfram Language outside of the notebook interface. Wolfram Workbench is a plugin for Eclipse, a popular and robust IDE.

Wolfram Workbench requires the following software:

We recommend having the latest version of these installed before setting up the Wolfram Workbench plugin.

To set up Wolfram Workbench, install the plugin inside Eclipse and configure it to point to your Mathematica installation:

  1. Start Eclipse.
  2. Select the menu item Help ► Install New Software. The Available Software dialog appears.
  3. Click the Add button near the top right-hand corner.
  4. Enter a name such as “Wolfram Workbench” into the Name field and http://workbench.wolfram.com/update/ into the Location field.


  5. If you have already downloaded the plugin from your Wolfram account, click Archive to locate WorkbenchUpdate_10.x.zip and add it directly.

  6. Click OK to confirm the site information. A list of Wolfram Workbench plugins is now displayed.
  7. Select Wolfram Workbench Core. Additionally, select Wolfram Workbench webMathematica if you plan on working with webMathematica. Click Next to confirm.
  8. In the Install Details window, click Next.
  9. In the Review Licenses window, review and accept the terms of the license agreements. Click Finish to begin the installation.
  10. Wolfram Workbench installs. During the installation, a security warning about unsigned content may appear; click “Install anyway” to continue.
  11. Restart Eclipse for the changes to take effect.

The Wolfram Workbench plugin is now installed. To verify, choose Help ► About Eclipse and identify the Wolfram Workbench logo toward the bottom of the window.

Configuring the Wolfram Workbench Plugin

If multiple versions of Mathematica are installed on your machine, you can select which version you would like Wolfram Workbench to use.

  1. Open the Eclipse Preferences (Windows/Linux: Window ► Preferences, Mac: Eclipse ► Preferences).
  2. Select the Wolfram category on left-hand side of the Preferences window. The available Wolfram Engines will be displayed.

    Installed versions of Mathematica within the list can be edited by selecting Edit, or further installations can be added by selecting Add and entering the product name and installation path.

  3. Choose your preferred Wolfram Engine installation. Click OK to confirm.
설명이 도움이 되었나요?
아니오

하실 말씀이 있습니까?

피드백 감사합니다.

제출하기

지원 문의

청구서, 제품 동기화에 관한 질문에서 기술적인 질문까지 부담없이 문의하세요.

1-800-WOLFRAM (국제 전화는 +1-217-398-0700)

고객 지원

월요일 - 금요일
8am–5pm 중부 표준시

  • 제품 등록 및 동기화
  • 구매 전 정보 및 주문
  • 설치 및 동작

고급 기술지원 (해당 고객을 대상으로)

월요일 - 목요일
8am–7pm 중부 표준시

금요일
8:30–10am & 11am–5pm 중부 표준시

  • 우선적 기술지원
  • Wolfram 전문가들의 제품 지원
  • Wolfram 프로그래밍
  • 고급 설치 지원