Wolfram Workbench is the recommended tool for programming in the Wolfram Language outside of the notebook interface. Wolfram Workbench is a plugin for Eclipse, a popular and robust IDE.

Wolfram Workbench requires the following software:

We recommend having the latest version of these installed before setting up the Wolfram Workbench plugin.

To set up Wolfram Workbench, install the plugin inside Eclipse and configure it to point to your Mathematica installation:

  1. Start Eclipse.
  2. Select the menu item Help ► Install New Software. The Available Software dialog appears.
  3. Click the Add button near the top right-hand corner.
  4. Enter a name such as “Wolfram Workbench” into the Name field and http://workbench.wolfram.com/update/ into the Location field.
  5. Click OK to confirm the site information. A list of Wolfram Workbench plugins is now displayed.
  6. Select Wolfram Workbench Core. Additionally, select Wolfram Workbench webMathematica if you plan on working with webMathematica. Click Next to confirm.
  7. In the Install Details window, click Next.
  8. In the Review Licenses window, review and accept the terms of the license agreements. Click Finish to begin the installation.
  9. Wolfram Workbench installs. During the installation, a security warning about unsigned content may appear; click OK to continue.
  10. Restart Eclipse for the changes to take effect.

The Wolfram Workbench plugin is now installed. To verify, choose Help ► About Eclipse and identify the Wolfram Workbench logo toward the bottom of the window.

Configuring the Wolfram Workbench Plugin

If multiple versions of Mathematica are installed on your machine, you can select which version you would like Wolfram Workbench to use.

  1. Open the Eclipse Preferences (Windows/Linux: Window ► Preferences, Mac: Eclipse ► Preferences).
  2. Select the Wolfram category on left-hand side of the Preferences window. The available Wolfram Engines will be displayed.

    Installed versions of Mathematica within the list can be edited by selecting Edit, or further installations can be added by selecting Add and entering the product name and installation path.

  3. Choose your preferred Wolfram Engine installation. Click OK to confirm.